N-at-han-k's Gems

icon
#Total RankDaily RankNameSummary
153,22310,376kube_clusterOOP abstraction that allows you to deploy and manage kubernetes resources using Ruby.
261,24310,376bruteProduction-grade coding agent with tool execution, middleware pipeline, context compact...
382,45124,061kube_schemaAbstractions are God. Let's give praise and build on the shoulders of giants by using o...
486,68442,533jekyll-importmapA plugin for jekyll to utilize importmaps
5115,11725,816async-matrixAsync-native Matrix protocol primitives built on the Socketry async ecosystem. Provides...
6116,21035,731gem_kit-releaseThe maintainer's half of gem_kit: one RubyGems command, `gem kit`, with subcommands for...
7124,57228,078ratalada-contribOptional add-on modules for ratalada that do not belong in the core gem. Require only t...
8128,00524,061rataladaDSL for running rack servers as easily as you can in javasript.
9128,91725,816kube_kubectlClone the repo and run bin/rename-gem and you have a gem.
10133,61924,061ratalada-sinatraSwaps ratalada's built-in router for a Sinatra DSL: require this and the Server.run blo...
11133,66842,533tailwind-jekyll-themeBase theme for using Tailwind CSS with Jekyll.
12136,10231,221ratalada-grapeSwaps ratalada's built-in router for a Grape DSL: require this and the Server.run block...
13138,05235,731ag-uiRuby server implementation of the AG-UI protocol (SSE event streaming, run loop, client...
14147,74242,533scampiScampi is a small RSpec clone weighing less than 350 LoC but nevertheless providing all...
15149,41835,731string_builderCaptures Ruby method chains into a buffer and serializes them to strings. Useful for bu...
16155,15431,221rails-active-uiA Rails engine providing view components built on ActiveModel::Attributes for type-safe...
17158,51225,816nkeys-rbNATS NKeys for Ruby, as a native extension over the Rust `nkeys` crate: Ed25519 keypair...
18159,77442,533agent2agentAbstraction to help work with A2A protocol
19169,58435,731frpc-rubyShips the upstream frpc binary for your platform and drives it from Ruby: spawn the cli...
20174,09119,007brute_cliInteractive command-line interface for the Brute coding agent. Supports single-prompt, ...
21174,09155,182gem_kit-plugingem_kit-release's `gem kit` command takes subcommands from other gems. This gem adds on...
22177,20755,182probsRepresenting probabilities with objects
23177,23755,182pg_cronpg_cron jobs scheduling for Rails
24179,74955,182protocol-smtpThe SMTP command/reply state machine (RFC 5321) and the message it assembles (RFC 5322)...
25179,85287,723async-smtpBinds protocol-smtp's state machine to an endpoint and runs it on the async reactor, on...
26180,27731,221remind-rbRemind is a calendar program with a real expression language behind it: a Hebrew calend...
27180,67955,182ratalada-hanamiSwaps ratalada's built-in router for the Hanami::API DSL: require this and the Server.r...
28182,21222,657mirrorfileMirrorfile provides a DSL similar to Bundler's Gemfile for managing local mirrors of gi...
29182,73128,078async-caldavNative server for CalDAV/CardDAV. Built on protocol-caldav for wire-format concerns.
30182,98655,182ratalada-rodaSwaps ratalada's built-in router for Roda's routing tree: require this and the Server.r...
31185,31435,731wrap_it_rubyWraps upstream web applications in an iframe via a same-origin reverse proxy. Provides ...
32185,71424,061brute_rackRack app exposing the Brute agent over HTTP with JSON and SSE streaming endpoints. Depl...
33185,71442,533colorize-extendedExtends the colorize gem with chainable syntax sugar like "hello".red.on.blue
34187,13435,731protocol-caldavPure protocol code for CalDAV (RFC 4791) and CardDAV (RFC 6352). No rack, no async, no ...
35187,21487,723jigsaw_engineJigsaw Engine
36187,65855,182xineramaProvides a clean Ruby interface to query Xinerama screen information for multi-monitor ...
37187,90525,816concat.rbA simple CLI tool that recursively reads files from directories and outputs their conte...
38189,29242,533remlintRemLint checks Remind reminder files for style, consistency and structure: unbalanced I...
39189,34142,533rem2icsRem2ics turns the reminder files used by Remind into iCalendar, the format Outlook, App...
40189,47555,182ralph.rbRalph Wiggum Loop - Iterative AI development with AI agents. An autonomous agentic loop...
41189,71028,078bpmn-js-railsbpmn-io/bpmn-js and form-js packaged as a Rails engine
42189,78842,533rubycamRubycam is a pure-Ruby V4L2 library for controlling webcams and capturing MJPG/YUYV fra...
43189,93542,533rubycam-gtkA GTK4 desktop viewer built on the rubycam library: live video preview, sliders for gim...
44190,17455,182gem_kitA deprecation is a dated promise: it names its replacement and the version the old name...
45190,38255,182concatA simple CLI tool that recursively reads files from directories and outputs their conte...
46190,38255,182emoji-validator-railsA Rails engine that provides validators to check if strings contain emojis using the un...
47190,43755,182operaton-bpm-clientA faithful Ruby recreation of the Operaton (org.operaton.bpm.client) Java external task...
48191,63113,082a2a-test-frameworkA comprehensive test framework for validating A2A protocol server implementations. Incl...
49191,67855,182mk.rbA CLI tool to create new projects from templates stored in ~/templates.
50192,61535,731brute_flowExtends the brute gem with a declarative BPMN workflow engine for multi-agent orchestra...
51192,78642,533kube_stationKubernetes on rails...
52192,82955,182milkdown_engineProvides a Milkdown-based rich markdown editor as a Rails engine with Stimulus controll...
53192,86255,182taskjuggler-railsRender Taskjuggler files (.tjp) as controller views.
54192,92442,533clip.rbA command-line tool for copying piped input to the clipboard with options for line limi...
55193,12842,533rufus-daemonRun rufus-scheduler in the background with a DRb unix socket. You can save schedule fil...
56193,50955,182kube_kitClone the repo and run bin/rename-gem and you have a gem.
57193,55355,182kube_engineKubeception
58195,42055,182notification_engineProvides controllers, views, and helpers for viewing and managing notifications created...
59195,48255,182ralphRalph Wiggum Loop - Iterative AI development with AI agents. An autonomous agentic loop...
60195,76642,533easy-peasy-apiA Rails Railtie that dynamically routes API requests to controllers based on the filesy...
61195,80755,182rack-charts-apiA mountable Rack app that accepts chartkick-compatible data via URL params or JSON requ...
62195,99055,182rack-forward-authPure Rack middleware that reads forward-auth headers (Remote-User, Remote-Email, Remote...