N-at-han-k's Gems

icon
#Total RankDaily RankNameSummary
152,03614,236kube_clusterOOP abstraction that allows you to deploy and manage kubernetes resources using Ruby.
260,72117,512bruteProduction-grade coding agent with tool execution, middleware pipeline, context compact...
381,43220,969kube_schemaAbstractions are God. Let's give praise and build on the shoulders of giants by using o...
486,38224,923jekyll-importmapA plugin for jekyll to utilize importmaps
593,4436,278async-matrixAsync-native Matrix protocol primitives built on the Socketry async ecosystem. A resour...
6114,1047,986gem_kit-releaseThe maintainer's half of gem_kit: one RubyGems command, `gem kit`, with subcommands for...
7117,59547,053agent2agentAbstraction to help work with A2A protocol
8122,28218,409ratalada-contribOptional add-on modules for ratalada that do not belong in the core gem. Require only t...
9124,64120,133rataladaDSL for running rack servers as easily as you can in javasript.
10127,39730,439kube_kubectlClone the repo and run bin/rename-gem and you have a gem.
11130,37020,969ratalada-sinatraSwaps ratalada's built-in router for a Sinatra DSL: require this and the Server.run blo...
12132,52527,173ratalada-grapeSwaps ratalada's built-in router for a Grape DSL: require this and the Server.run block...
13133,49979,573tailwind-jekyll-themeBase theme for using Tailwind CSS with Jekyll.
14137,62435,872ag-uiRuby server implementation of the AG-UI protocol (SSE event streaming, run loop, client...
15145,87022,034string_builderCaptures Ruby method chains into a buffer and serializes them to strings. Useful for bu...
16146,35930,439scampiScampi is a small RSpec clone weighing less than 350 LoC but nevertheless providing all...
17153,52647,053rails-active-uiA Rails engine providing view components built on ActiveModel::Attributes for type-safe...
18157,54635,872nkeys-rbNATS NKeys for Ruby, as a native extension over the Rust `nkeys` crate: Ed25519 keypair...
19169,07230,439frpc-rubyShips the upstream frpc binary for your platform and drives it from Ruby: spawn the cli...
20173,44847,053brute_cliInteractive command-line interface for the Brute coding agent. Supports single-prompt, ...
21174,12735,872gem_kit-plugingem_kit-release's `gem kit` command takes subcommands from other gems. This gem adds on...
22177,06047,053pg_cronpg_cron jobs scheduling for Rails
23177,32979,573probsRepresenting probabilities with objects
24178,19820,969ratalada-hanamiSwaps ratalada's built-in router for the Hanami::API DSL: require this and the Server.r...
25179,67835,872protocol-smtpThe SMTP command/reply state machine (RFC 5321) and the message it assembles (RFC 5322)...
26179,80335,872async-smtpBinds protocol-smtp's state machine to an endpoint and runs it on the async reactor, on...
27179,87447,053remind-rbRemind is a calendar program with a real expression language behind it: a Hebrew calend...
28181,54023,284ratalada-rodaSwaps ratalada's built-in router for Roda's routing tree: require this and the Server.r...
29182,09035,872mirrorfileMirrorfile provides a DSL similar to Bundler's Gemfile for managing local mirrors of gi...
30182,60547,053async-caldavNative server for CalDAV/CardDAV. Built on protocol-caldav for wire-format concerns.
31185,17935,872wrap_it_rubyWraps upstream web applications in an iframe via a same-origin reverse proxy. Provides ...
32185,65435,872colorize-extendedExtends the colorize gem with chainable syntax sugar like "hello".red.on.blue
33185,70079,573brute_rackRack app exposing the Brute agent over HTTP with JSON and SSE streaming endpoints. Depl...
34187,08647,053protocol-caldavPure protocol code for CalDAV (RFC 4791) and CardDAV (RFC 6352). No rack, no async, no ...
35187,16835,872jigsaw_engineJigsaw Engine
36187,71579,573xineramaProvides a clean Ruby interface to query Xinerama screen information for multi-monitor ...
37187,85779,573concat.rbA simple CLI tool that recursively reads files from directories and outputs their conte...
38188,3507,307gem_kitA deprecation is a dated promise: it names its replacement and the version the old name...
39189,34447,053ralph.rbRalph Wiggum Loop - Iterative AI development with AI agents. An autonomous agentic loop...
40189,37047,053remlintRemLint checks Remind reminder files for style, consistency and structure: unbalanced I...
41189,42447,053rem2icsRem2ics turns the reminder files used by Remind into iCalendar, the format Outlook, App...
42189,69779,573bpmn-js-railsbpmn-io/bpmn-js and form-js packaged as a Rails engine
43189,75420,133emoji-validator-railsA Rails engine that provides validators to check if strings contain emojis using the un...
44189,86547,053rubycamRubycam is a pure-Ruby V4L2 library for controlling webcams and capturing MJPG/YUYV fra...
45190,03147,053rubycam-gtkA GTK4 desktop viewer built on the rubycam library: live video preview, sliders for gim...
46190,48279,573concatA simple CLI tool that recursively reads files from directories and outputs their conte...
47190,49047,053operaton-bpm-clientA faithful Ruby recreation of the Operaton (org.operaton.bpm.client) Java external task...
48190,98035,872a2a-test-frameworkA comprehensive test framework for validating A2A protocol server implementations. Incl...
49191,68379,573mk.rbA CLI tool to create new projects from templates stored in ~/templates.
50192,64135,872brute_flowExtends the brute gem with a declarative BPMN workflow engine for multi-agent orchestra...
51192,75447,053kube_stationKubernetes on rails...
52192,80879,573milkdown_engineProvides a Milkdown-based rich markdown editor as a Rails engine with Stimulus controll...
53192,91679,573taskjuggler-railsRender Taskjuggler files (.tjp) as controller views.
54192,96979,573clip.rbA command-line tool for copying piped input to the clipboard with options for line limi...
55193,16279,573rufus-daemonRun rufus-scheduler in the background with a DRb unix socket. You can save schedule fil...
56193,51347,053kube_kitClone the repo and run bin/rename-gem and you have a gem.
57193,53547,053kube_engineKubeception
58195,48079,573ralphRalph Wiggum Loop - Iterative AI development with AI agents. An autonomous agentic loop...
59195,53779,573notification_engineProvides controllers, views, and helpers for viewing and managing notifications created...
60195,89879,573easy-peasy-apiA Rails Railtie that dynamically routes API requests to controllers based on the filesy...
61195,96879,573rack-charts-apiA mountable Rack app that accepts chartkick-compatible data via URL params or JSON requ...
62196,14147,053rack-forward-authPure Rack middleware that reads forward-auth headers (Remote-User, Remote-Email, Remote...