| 1 | 50,669 | 18,605 | kube_cluster | OOP abstraction that allows you to deploy and manage kubernetes resources using Ruby. |
| 2 | 59,695 | 24,500 | brute | Production-grade coding agent with tool execution, middleware pipeline, context compact... |
| 3 | 78,627 | 26,551 | kube_schema | Abstractions are God. Let's give praise and build on the shoulders of giants by using o... |
| 4 | 86,060 | 54,338 | jekyll-importmap | A plugin for jekyll to utilize importmaps |
| 5 | 87,074 | 16,183 | async-matrix | Async-native Matrix protocol primitives built on the Socketry async ecosystem. A resour... |
| 6 | 109,211 | 6,863 | gem_kit-release | The maintainer's half of gem_kit: one RubyGems command, `gem kit`, with
subcommands for... |
| 7 | 116,076 | 23,689 | agent2agent | Abstraction to help work with A2A protocol |
| 8 | 118,185 | 30,067 | ratalada-contrib | Optional add-on modules for ratalada that do not belong in the core gem.
Require only t... |
| 9 | 118,457 | 26,551 | ratalada | DSL for running rack servers as easily as you can in javasript. |
| 10 | 125,772 | 54,338 | kube_kubectl | Clone the repo and run bin/rename-gem and you have a gem. |
| 11 | 129,263 | 32,758 | ratalada-sinatra | Swaps ratalada's built-in router for a Sinatra DSL: require this and the
Server.run blo... |
| 12 | 131,184 | 32,758 | ratalada-grape | Swaps ratalada's built-in router for a Grape DSL: require this and the
Server.run block... |
| 13 | 133,257 | 54,338 | tailwind-jekyll-theme | Base theme for using Tailwind CSS with Jekyll. |
| 14 | 136,941 | 88,151 | ag-ui | Ruby server implementation of the AG-UI protocol (SSE event streaming, run loop, client... |
| 15 | 144,032 | 54,338 | string_builder | Captures Ruby method chains into a buffer and serializes them to strings. Useful for bu... |
| 16 | 144,321 | 24,500 | scampi | Scampi is a small RSpec clone weighing less than 350 LoC but
nevertheless providing all... |
| 17 | 152,726 | 42,569 | rails-active-ui | A Rails engine providing view components built on ActiveModel::Attributes for type-safe... |
| 18 | 155,940 | 42,569 | nkeys-rb | NATS NKeys for Ruby, as a native extension over the Rust `nkeys` crate: Ed25519 keypair... |
| 19 | 167,775 | 16,325 | vodozemac | Olm and Megolm for Ruby, over the vodozemac crate by magnus. Accounts, sessions, group ... |
| 20 | 168,755 | 42,569 | frpc-ruby | Ships the upstream frpc binary for your platform and drives it from Ruby:
spawn the cli... |
| 21 | 172,409 | 88,151 | brute_cli | Interactive command-line interface for the Brute coding agent. Supports single-prompt, ... |
| 22 | 174,287 | 54,338 | gem_kit-plugin | gem_kit-release's `gem kit` command takes subcommands from other gems. This
gem adds on... |
| 23 | 176,570 | 30,067 | ratalada-hanami | Swaps ratalada's built-in router for the Hanami::API DSL: require this and
the Server.r... |
| 24 | 177,185 | 88,151 | pg_cron | pg_cron jobs scheduling for Rails |
| 25 | 177,640 | 88,151 | probs | Representing probabilities with objects |
| 26 | 179,502 | 88,151 | remind-rb | Remind is a calendar program with a real expression language behind it: a
Hebrew calend... |
| 27 | 179,603 | 28,108 | protocol-smtp | The SMTP command/reply state machine (RFC 5321) and the message it
assembles (RFC 5322)... |
| 28 | 179,789 | 28,108 | async-smtp | Binds protocol-smtp's state machine to an endpoint and runs it on the
async reactor, on... |
| 29 | 180,843 | 42,569 | mirrorfile | Mirrorfile provides a DSL similar to Bundler's Gemfile for managing local
mirrors of gi... |
| 30 | 180,992 | 42,569 | ratalada-roda | Swaps ratalada's built-in router for Roda's routing tree: require this and
the Server.r... |
| 31 | 182,572 | 26,551 | async-caldav | Native server for CalDAV/CardDAV.
Built on protocol-caldav for wire-format concerns. |
| 32 | 183,096 | 6,266 | gem_kit | A deprecation is a dated promise: it names its replacement and the version
the old name... |
| 33 | 185,397 | 88,151 | wrap_it_ruby | Wraps upstream web applications in an iframe via a same-origin reverse proxy. Provides ... |
| 34 | 185,572 | 88,151 | colorize-extended | Extends the colorize gem with chainable syntax sugar like "hello".red.on.blue |
| 35 | 185,864 | 88,151 | brute_rack | Rack app exposing the Brute agent over HTTP with JSON and SSE streaming endpoints. Depl... |
| 36 | 187,278 | 88,151 | protocol-caldav | Pure protocol code for CalDAV (RFC 4791) and CardDAV (RFC 6352).
No rack, no async, no ... |
| 37 | 187,379 | 88,151 | jigsaw_engine | Jigsaw Engine |
| 38 | 188,043 | 54,338 | xinerama | Provides a clean Ruby interface to query Xinerama screen information for multi-monitor ... |
| 39 | 188,043 | 54,338 | concat.rb | A simple CLI tool that recursively reads files from directories and outputs
their conte... |
| 40 | 189,113 | 28,108 | ralph.rb | Ralph Wiggum Loop - Iterative AI development with AI agents.
An autonomous agentic loop... |
| 41 | 189,291 | 26,551 | emoji-validator-rails | A Rails engine that provides validators to check if strings contain emojis using the un... |
| 42 | 189,725 | 88,151 | remlint | RemLint checks Remind reminder files for style, consistency and structure:
unbalanced I... |
| 43 | 189,762 | 88,151 | rem2ics | Rem2ics turns the reminder files used by Remind into iCalendar, the format
Outlook, App... |
| 44 | 190,002 | 88,151 | bpmn-js-rails | bpmn-io/bpmn-js and form-js packaged as a Rails engine |
| 45 | 190,233 | 88,151 | rubycam | Rubycam is a pure-Ruby V4L2 library for controlling webcams and capturing
MJPG/YUYV fra... |
| 46 | 190,401 | 88,151 | rubycam-gtk | A GTK4 desktop viewer built on the rubycam library: live video preview,
sliders for gim... |
| 47 | 190,819 | 54,338 | concat | A simple CLI tool that recursively reads files from directories and outputs
their conte... |
| 48 | 190,852 | 54,338 | operaton-bpm-client | A faithful Ruby recreation of the Operaton (org.operaton.bpm.client) Java external task... |
| 49 | 191,217 | 88,151 | a2a-test-framework | A comprehensive test framework for validating A2A protocol server implementations. Incl... |
| 50 | 192,213 | 88,151 | mk.rb | A CLI tool to create new projects from templates stored in ~/templates. |
| 51 | 193,208 | 88,151 | brute_flow | Extends the brute gem with a declarative BPMN workflow engine for multi-agent orchestra... |
| 52 | 193,439 | 88,151 | kube_station | Kubernetes on rails... |
| 53 | 193,512 | 54,338 | milkdown_engine | Provides a Milkdown-based rich markdown editor as a Rails engine with Stimulus controll... |
| 54 | 193,602 | 88,151 | taskjuggler-rails | Render Taskjuggler files (.tjp) as controller views. |
| 55 | 193,602 | 88,151 | clip.rb | A command-line tool for copying piped input to the clipboard with options
for line limi... |
| 56 | 193,855 | 88,151 | rufus-daemon | Run rufus-scheduler in the background with a DRb unix socket.
You can save schedule fil... |
| 57 | 194,145 | 36,652 | kube_kit | Clone the repo and run bin/rename-gem and you have a gem. |
| 58 | 194,263 | 88,151 | kube_engine | Kubeception |
| 59 | 194,533 | 16,456 | rubocop-nathank | House style, as a RuboCop plugin. |
| 60 | 194,826 | 54,338 | async-vikunja | An asynchronous Ruby client for the Vikunja API. |
| 61 | 195,658 | 30,067 | ralph | Ralph Wiggum Loop - Iterative AI development with AI agents. An autonomous agentic loop... |
| 62 | 195,902 | 36,652 | async-matrix-bridge | The server side of a Matrix bridge or bot: a Rack application that authenticates and de... |
| 63 | 196,218 | 42,569 | notification_engine | Provides controllers, views, and helpers for viewing and managing notifications created... |
| 64 | 196,567 | 88,151 | easy-peasy-api | A Rails Railtie that dynamically routes API requests to controllers based on the filesy... |
| 65 | 196,619 | 88,151 | rack-charts-api | A mountable Rack app that accepts chartkick-compatible data via URL params or JSON requ... |
| 66 | 196,804 | 88,151 | rack-forward-auth | Pure Rack middleware that reads forward-auth headers (Remote-User, Remote-Email, Remote... |
| 67 | 196,925 | 88,151 | active_record_pgnats | Adds methods to ActiveRecord::Migration to manage pgnats: its foreign server,
its subje... |
| 68 | 197,006 | 88,151 | active_record_pgnats-rails | Hooks active_record_pgnats into Rails at the on_load :active_record moment
and adds gen... |
| 69 | 197,042 | 42,569 | hey.rb | hey sends load to a web application and reports a latency histogram, percentile distrib... |
| 70 | 197,362 | 88,151 | async-firefly | An asynchronous Ruby client for the Firefly III API. |